Should we upgrade to StyleCop 4.7?

Coordinator
Jan 10, 2012 at 7:37 PM

Hey guys,

Could please anyone tell whether they need new StyleCop+ version for the latest StyleCop 4.7 release?

As for me, I did not switched to 4.7 yet, and saw lots of issues regarding performance.
I think there will be more 4.7 releases in the nearest future, but if the majority of StyleCop+ users have already upgraded to 4.7 - I will definitely build StyleCop+ over 4.7.

Would be glad to hear your opinions.

Best regards,
Oleg Shuruev

Jan 11, 2012 at 9:45 AM

Hi Oleg,

yes we need a new Version, because some of our developers want to swtich to the new Resharper 6.1 and so i have to switch the Stylecop too.

But is there no way to build that without that hard link to a special Assembly Version. In the Config you cann made things like a dependency redirect of an assembly.

Best regards,

Erik

 

Jan 11, 2012 at 2:37 PM

Hi Oleg,

same here. We are also using Resharper and would like to switch to Resharper 6.1. But without StyleCop/StyleCop+ we will wait to switch until there is a working combination of R# 6.1/6.x & StyleCop & StyleCop+. At the moment only StyleCop+ is missing. So it would be be very helpful if you could build a version for StyleCop 4.7.x.

Best Regards,

Torsten

Jan 12, 2012 at 1:04 AM

Hi Oleg,

Same here.

Dejan

Jan 13, 2012 at 4:35 PM

Yes please. Even though I'm not using R# 6.1 yet, I'd still like to have StyleCop+ working with my StyleCop 4.7 install.

Coordinator
Jan 15, 2012 at 10:44 PM

Hi everybody,

I've just released new StyleCop+ 1.6 version, that is build over StyleCop 4.7.5.0 (note, the newest one).
Some new features were also implemented, you're welcome to see the change log for details.

I also would like to say that I really appreciate your attention to this plug-in and will try to give it more time for further development.

Thank you, guys!

Best regards,
Oleg Shuruev