Always No violations encountered using Stylecop programmatically

first post: andrerios wrote: Hi, I have a .NET 4.0 Console app with referencies to 'StyleCop.d...

latest post: savstavr wrote: I have same problem, can anyone help me?

Request for custom regex rule

first post: anderam wrote: Would be nice if there will be Custom regex rule, which user can na...

latest post: shuruev wrote: Hi, I probably understand what you mean, even though cannot promis...

Is it possible to create Style rules for PowerShell Scripts with StyleCop?

first post: ievgen wrote: I'm new to this tool, but from what I understand it works only with...

latest post: shuruev wrote: No, I'm afraid at the moment StyleCop is for C# only. Even though i...

Naming: UpperCase with Underscores

first post: GhostSquad wrote: I'm trying to get a naming rule to work for my test methods. UpperC...

latest post: shuruev wrote: $(AaBb)_$(AaBb)_$(AaBb) template would catch the names like you men...

answered by: shuruev wrote: $(AaBb)_$(AaBb)_$(AaBb) template would catch the names like you men...

SA1500 Alternative

first post: GhostSquad wrote: This is a suggestion to allow a custom rule to enforce either havin...

Resharper+StyleCop integration

first post: mwpowellhtx wrote: Hello, I am now successfully extending StyleCop (non-plus?) with ...

latest post: shuruev wrote: Hi mwpowellhtx, As for me, I don't use R# features of StyleCop and...

Call to AddSourceFile() always returns false when not using VS2010 test-runner

first post: weberse wrote: I found lots of examples for testing custom rules using MSTest and ...

Integration with SonarQube

first post: angegar wrote: Hello all, I would like to know if someone already used StyleCopPl...

Namspace with dot (".")

first post: trbaphong wrote: I want to check whether all namespace begin with "App." or not. Ho...

Exception Loading StyleCop+

first post: ThomasW wrote: Hi I am getting an Exception, when I copy StyleCopPlus.dll into th...

latest post: adhemar82 wrote: *Edit* Never mind, I found out what the issue was for me. It seems...